Engine Room

From AardRock Wiki
Revision as of 10:38, 31 December 2012 by Martien (talk | contribs) (KPN Chicago 370 via Fritz!Box 7170: Safari » Extension » ClickToPlugin)
Jump to: navigation, search

Welcome to AardRock's Engine Room—The place where all instruments, tools and infrastructure come to live and evolve.

hdutil mount sparsebundle

sudo hdiutil mount -nomount -readwrite /Volumes/Ayers\ Rock/Myrrh_0016cbcbeab1.sparsebundle

Scan & OCR book with Acrobat

  1. scan at 200 dpi, black & white, png file (~64 KB/page) into single folder
  2. use acrobat to combine folder into single pdf
  3. OCR resulting file
  4. export text as RTF

Convert Google book to plain text

  1. In Safari:
    1. Open Google book
    2. Point at page image
    3. Safari > Inspect Element: opens hood
    4. Click Resources tab: shows list of book page images
    5. Double-click desired page: opens separate window with page
    6. Save Image As… creates an image with DIP set to absurd high value (millions of DPI)
  2. In Preview
    1. Open image
    2. Select Tools > Adjust Size…
    3. Set Resolution to 72 pixels/inch
    4. Save image. (⌘-S)
  3. In Acrobat Professional:
    1. Create PDF > From File…
    2. Select image just saved
    3. Select Document > OCR Text Recognition > Recognize Text Using OCR…

Now you can select, copy and paste normal text. You can also File > Export > Rich Text Format…

Apache alias to map www.domainname.tld to just domainname.tld

To have, say www.visionier.nl automatically map to visionier.nl:

  1. Create a DNS CNAME that creates this map.
  2. Add a ServerAlias www.domain name.tld to the <VirtualHost IP-address:80>, e.g. ServerAlias www.visionier.nl added to <VirtualHost 80.84.230.245:80> will do the trick.

rsync

Always run rsync through ssh:

rsync  -e 'ssh -l ssh_account' -vaz src_dir target_tld:dst_dir

xattr: set where from

Sometimes the ‘where from’ metadata contains an unreadable URL from some cache. Replace it with the most human readable version of the original. This way, you can always find out the source of the original document (image, movie, etc.).

xattr -w 'com.apple.metadata:kMDItemWhereFroms' source_url file_name

xattr: UTF-8 copy & paste

Mac OS X stores a special attribute: http://www.nabble.com/MacVim-file-encoding-and-Quicklook-td17289501.html

To create an UTF-8 file using vi(1) and open it correctly as UTF-8 file in TextEdit (as opposed to Open As… UTF-8):

  1. vi file
  2. xattr -w com.apple.TextEncoding 'UTF-8;134217984' file
  3. open file


Cobble

See Cobble for it's IP address.

Server Room

Please see Engine Room/Server.

Wiki installation

Mailing Lists

NOTA BENE:

  • Adding and removing mailing lists is done using Plesk.
  • Managing mailing lists (posts, subscription, digests) is done using MailMan directly.

To add a new mailing list:

  1. Login to Plesk as administrator.
  2. Select Domains in the General section of the left navigation bar.
  3. Select the domain to which you want to add a mailing list, e.g. aardrock.
  4. Select Mail under Services.
  5. Select the Mailing lists tab.
  6. Select Add new mailing list.
  7. Enter the mailing list name, password and administrators email and press OK.

To manage mailing lists:

URLs and subdomains

To add a redirection

  1. Login on server
  2. Switch directory to the subdomain's directory.
  3. Create the directory.
  4. Create index.php containing the Location: header instruction.

For example, to have http://cheetah.aardrock.com/faq/ redirect to http://wiki.aardrock.com/Cheetah_FAQ:

# cd /var/www/vhosts/aardrock.com/subdomains/cheetah/httpdocs
# mkdir faq
# echo '<? header("Location: http://wiki.aardrock.com/Cheetah_FAQ"); ?>' > index.php

Publishing presentations online

To publish a presentation online:

  1. In Keynote, choose File > Export.
  2. Select the HTML tab.
  3. Select Format > JPEG (variable quality).
  4. Set Quality > 50%
  5. Click Next; the Save As dialog appears.
  6. Enter a descriptive name for your presentation, as this is used in all subseqent communication.
  7. Click Export. Keynote will start exporting the HTML
    Note that a HTML file with name presentation.html is generated along with a folder called presentation_files containing slide images.

Next, use ImageMagick to convert the high-resolution images into more convenient low resulotion images.

  1.  % cd presentation_files
  2.  % mkdir hi
  3.  % mv *.jpg hi
  4.  % cd hi
  5.  % convert -verbose -crop '1008x768+0+0!' 'presentation.*.jpg[504x384]' ../presentation.%03d.jpg


Create PDF booklet with InDesign CS5 on Snow Leopard

  1. In InDesign:
    1. Select File > Print Booklet…
    2. Click Print Settings…
    3. Select Printer > PostScript® File (optionally Save Preset…).
    4. Click OK.
    5. Click Print.
    6. Enter file name in Save As.
    7. Click Save.
  2. In Finder:
    1. Open PostScript file in Preview (this converts PostScript to PDF).
    2. Select File > Save.
    3. Enter file name and click Save.

For more information, see InDesignSecrets » Acrobat’s Adobe PDF Printer Replaced in Snow Leopard

SVN

  • Alle svn data staat op /var/svn/repositories
To list the AardRock repository:

of, wanneer ingelogd op svn server:

  • svn list file:///var/svn/repositories/AardRock/trunk/MediaWikiSkin/
To check out the AardRock repository:
To check in changed files into the repository:
  • svn commit

NOTE: you must be in the directory containing the working files, or specify the path.

To see differences between revision X and your current working version of main.css:
  • svn diff -rX main.css
  • svn diff -r2:7 main.css
To get an overview of all revisions of upload do:
  • svn log upload
To install:
  • ARUN=martien ./upload
To create a working copy of the complete repository:
  • svn co file:///var/svn/repositories/AardRock
To create a new project in the AardRock repository:

Either:

  • cd AardRock/trunk/
  • mkdir Apache
  • svn add Apache
  • svn commit

Or import an existing directory into the desired location in the AardRock trunk:

  • mkdir Apache
  • svn import Apache file:///var/svn/repositories/AardRock/trunk/Apache

HP scanjet 4670

Nice vertical flatbed scanner but shitty crappy software. Come on HP, you can do better! After upgrade to Mac OS X 10.5.8 scanner did not work anymore.

  • First, follow instructions on hp scanjet 4670 and OS X 10.4.8 -- YIKES! » I Did Get It Going....
  • Next, follow instructions on Scanjet 4670 driver for Mac OS Leopard 10.5? » Kenneth Koller's comment.
    1. Download COL10842b.dmg
    2. Double-click COL10842b.dmg to mount.
    3. Once the window opens with the installers...control click it...and select see package contents.
    4. Navigate to contents/macos/subinstallers.
    5. Double-click on the hp scanjet 4600.
    6. Go to top directory of SJ4600 (mount point *.dmg) and double-click HP ScanJet Software Installer to install all components (not sure if this is still necessary).
    7. Enjoy

I will never buy any HP products anymore.

Mac OS X 10.5 and Apache Tomcat

LaCie Big Disk 500 GB d2

Moved to LaCie.

Apple Might Mouse operatie schoon schip

De Mighty Mouse scrollde niet meer naar beneden, alleen nog maar naar boven. Schoonmaken volgens de ‘Apple methode’ leverde geen resultaat meer op, dus bleef er nog maar één ding over:

Met succes uitgevoerd op 2010-10-13.

KPN Chicago 370 via Fritz!Box 7170

  • connect 370 with standard UTP cable to Fritz!Box port ???
  • configure telephone device and phone numbers on Fritz!Box
  • reset Chicago 370
  • set date and time
  • send phonebook from one of handsets to base station (370)
  • set ISDN MSN number without leading zero (e.g. 347326430)

Download YouTube Video

Safari » Extension » ClickToPlugin